Patch "xfs: rename xfs_iomap_swapfile_activate to xfs_vm_swap_activate" has been added to the 6.12-stable tree
<[email protected]> Tue, 29 Apr 2025 09:35:13 +0200
| Newsgroups | dev.linux.lists.xfs-stable |
|---|---|
| Message-ID | <2025042913-preamble-wrongness-768a@gregkh> |
This is a note to let you know that I've just added the patch titled
xfs: rename xfs_iomap_swapfile_activate to xfs_vm_swap_activate
to the 6.12-stable tree which can be found at:
http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary
The filename of the patch is:
xfs-rename-xfs_iomap_swapfile_activate-to-xfs_vm_swap_activate.patch
and it can be found in the queue-6.12 subdirectory.
If you, or anyone else, feels it should not be added to the stable tree,
please let <[email protected]> know about it.
From [email protected] Mon Apr 28 20:39:56 2025
From: "Darrick J. Wong" <[email protected]>
Date: Mon, 28 Apr 2025 11:39:51 -0700
Subject: xfs: rename xfs_iomap_swapfile_activate to xfs_vm_swap_activate
To: [email protected], [email protected]
Cc: [email protected], [email protected], [email protected], [email protected]
Message-ID: <174586545440.480536.11026423037943384392.stgit@frogsfrogsfrogs>
From: Christoph Hellwig <[email protected]>
Commit 3cd6a8056f5a2e794c42fc2114ee2611e358b357 upstream
Match the method name and the naming convention or address_space
operations.
Signed-off-by: Christoph Hellwig <[email protected]>
Reviewed-by: Darrick J. Wong <[email protected]>
Reviewed-by: Dave Chinner <[email protected]>
Signed-off-by: Carlos Maiolino <[email protected]>
Signed-off-by: Greg Kroah-Hartman <[email protected]>
---
fs/xfs/xfs_aops.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- a/fs/xfs/xfs_aops.c
+++ b/fs/xfs/xfs_aops.c
@@ -528,7 +528,7 @@ xfs_vm_readahead(
}
static int
-xfs_iomap_swapfile_activate(
+xfs_vm_swap_activate(
struct swap_info_struct *sis,
struct file *swap_file,
sector_t *span)
@@ -549,11 +549,11 @@ const struct address_space_operations xf
.migrate_folio = filemap_migrate_folio,
.is_partially_uptodate = iomap_is_partially_uptodate,
.error_remove_folio = generic_error_remove_folio,
- .swap_activate = xfs_iomap_swapfile_activate,
+ .swap_activate = xfs_vm_swap_activate,
};
const struct address_space_operations xfs_dax_aops = {
.writepages = xfs_dax_writepages,
.dirty_folio = noop_dirty_folio,
- .swap_activate = xfs_iomap_swapfile_activate,
+ .swap_activate = xfs_vm_swap_activate,
};
Patches currently in stable-queue which might be from [email protected] are
queue-6.12/xfs-do-not-check-needsrepair-if-ro-norecovery-mount.patch
queue-6.12/xfs-do-not-allow-norecovery-mount-with-quotacheck.patch
queue-6.12/iomap-skip-unnecessary-ifs_block_is_uptodate-check.patch
queue-6.12/xfs-flush-inodegc-before-swapon.patch
queue-6.12/xfs-rename-xfs_iomap_swapfile_activate-to-xfs_vm_swap_activate.patch