Re: [f2fs-dev] [RFC PATCH v2 02/10] f2fs: carry subpage offset and count in write IO
Nanzhe Zhao via Linux-f2fs-devel <[email protected]>
| Newsgroups | net.sourceforge.lists.linux-f2fs-devel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
> How about cleaning up w/ below macros? > > #define F2FS_FOLIO_INDEX(folio, fio) (folio->index + fio->folio_offset) > #define F2FS_FOLIO_BLKCNT(fio) (fio->folio_blkcnt ? fio->folio_blkcnt : 1) F2FS_FOLIO_XXX naming seems a bit weird to me :). It does not show that we want to use the folio subpage index associated with fio, or the blkcnt recorded in fio. I think names like F2FS_FIO_LBLK and F2FS_FIO_BLKCNT may be better? _______________________________________________ Linux-f2fs-devel mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/linux-f2fs-devel