Re: [f2fs-dev] [PATCH] fs: report direct io constraints through file_getattr
Christoph Hellwig <[email protected]>
| Newsgroups | net.sourceforge.lists.linux-f2fs-devel,org.kernel.vger.linux-block,org.kernel.vger.linux-ext4,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-xfs |
|---|---|
| Message-ID | <[email protected]> |
On Thu, Jul 09, 2026 at 07:46:42AM -0600, Keith Busch wrote: > On Thu, Jul 09, 2026 at 09:13:52AM +0200, Christoph Hellwig wrote: > > On Tue, Jul 07, 2026 at 06:18:43PM -0700, Keith Busch wrote: > > > > > + fa->fsx_dio_mem_align = bdev_dma_alignment(bdev) + 1; > > > + fa->fsx_dio_offset_align = bdev_logical_block_size(bdev); > > > + fa->fsx_dio_read_offset_align = bdev_logical_block_size(bdev); > > > + fa->fsx_dio_virt_boundary_align = bdev_virt_boundary_alignment(bdev); > > > + fa->fsx_max_segments = bdev_max_segments(bdev); > > > > How is the max_segments value defined in a way that is meaningful to > > userspace? > > It tells you how many sub-sector vectors you can submit in your > readv/writev before it needs to add up to a logical block size. > > Ex: 4k logical block size, 4 byte DMA, 256 max segments. You can define > 4-byte iov's in your command, but you'll hit the max segment count > before you have a valid IO if they're all that small. Ah, makes sense. But besides the missing documentation I think max_segments is a bit of a misleading name for that. Something like max_vecs_per_block (although we don't expose blocks in the UAPI) or max_vecs_per_granularity (I think grammar wants a word with me for that, though...) might be a bit more suitable. > > > @@ -145,6 +155,8 @@ static int file_attr_to_fileattr(const struct file_attr *fattr, > > > > > > if (fattr->fa_xflags & ~mask) > > > return -EINVAL; > > > + if (fattr->fa_pad) > > > + return -EINVAL; > > > > How is this related? > > I had to add a padding field to the struct to account for the implicit > hole in 64-bit and to ensure the struct is the same size for 32-bit. > It's a reserved field, so we have to ensure the current kernel doesn't > support any value here in case we define this field for something else > in the future. Ah, right. _______________________________________________ Linux-f2fs-devel mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/linux-f2fs-devel