[linux-nfc] Re: [PATCH v2] tag: Implement readout of tag UID via DBus interface

Frieder Schrempf <[email protected]> Tue, 10 Aug 2021 11:58:31 +0200
Newsgroups org.01.lists.linux-nfc,dev.linux.lists.oe-linux-nfc
Message-ID <[email protected]>
On 08.08.21 03:55, Mark Greer wrote:
> On Thu, Mar 18, 2021 at 05:14:35PM +0100, Frieder Schrempf wrote:
>> Hi Fabian,
>>
>> On 16.03.21 19:49, Gottstein, Fabian wrote:
>>> Hi Frieder,
>>>
>>> thanks for the patch.
>>
>> thanks for your feedback.
>>
>>>
>>> Could you please also consider the following situation:
>>> In the case of a NFC Tag Type 1, the identifier is delivered via the RID command (see NFC Digital Protocol). Thus, the Tag's nfcid property is updated in a later step.
>>> To inform the neard users, a property changed signal has to be emitted when nfcid has changed (in near_tag_set_nfcid). Also, a exists() handler for the new DBus property should be implemented.
>>
>> I'm new to NFC and D-Bus, so I don't know much about what use-cases and
>> requirements there are.
>>
>> Your request sounds reasonable and I think I have a rough understanding of
>> what is probably needed to implement this. Still to actually do this I need
>> to look at the specifications and the code more closely and I don't know
>> if/when I will find time to do this.
>>
>> Also I don't have any hardware to test this with NFC type 1 tags.
>>
>>>
>>> Another thing regarding building the response message:
>>> The following code snippet could simplify and improve the readability of the usage of the dbus message builder:
>>>
>>> dbus_message_iter_open_container(iter, DBUS_TYPE_ARRAY, DBUS_TYPE_BYTE_AS_STRING, &entry);
>>> dbus_message_iter_append_fixed_array(&entry, DBUS_TYPE_BYTE, &uid, len);
>>> dbus_message_iter_close_container(iter, &entry);
>>>
>> Thanks for the improved code, I will use this instead.
>>
>> Frieder
> 
> Hi Frieder.
> 
> Do you have an updated version of this patch (or did I miss it)?

No, unfortunately not. I implemented this fix for a project that is now discontinued. I can try to find some time in my spare time to implement at least Fabian's code improvement suggestion. But I don't know if it makes sense to upstream this without the changes Fabian suggested in regard to NFC Tag Type 1 and I currently have neither time to dig into this, nor hardware to test it.

_______________________________________________
Linux-nfc mailing list -- [email protected]
To unsubscribe send an email to [email protected]
%(web_page_url)slistinfo%(cgiext)s/%(_internal_name)s