[ath9k-devel] ath9k: extend and improve handling of ath9k_platform_data

Martin Blumenstingl <[email protected]>
Newsgroups org.ath9k.lists.ath9k-devel,org.kernel.vger.linux-wireless
Message-ID <[email protected]>
This series improves handling of ath9k_platform_data inside ath9k. A
quick summary of the changes is:
- led_active_high can now be configured via ath9k_platform_data:
  This change is based on a patch originally written by Vittorio
  Gambaletta which is part of OpenWrt's ath9k patches.
- small code cleanups which include removal of unused variables,
  return values duplicate code (no functional changes)
- ath9k_hw_init_macaddr will not change common->macaddr anymore
  to make it independent of whether it's called before or after
  ath9k_platform_data initialization in init.c
- initialization based on ath9k_platform_data in init.c is now
  easier to understand (no functional changes)

Patch 6 from this series supersedes the following patch by Eduardo
Abinader: "ath9k: return false when reading wrong eeprom offset" [0]


[0] https://patchwork.kernel.org/patch/9181371/
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.