[RFC 0/2] bpf_def.h cleanups

Marat Khalili <[email protected]>
Newsgroups org.dpdk.dev
Message-ID <[email protected]>
This patch set contains two patches, first of which is a prerequisite
for the second but can also be considered and applied independently.

Marat Khalili (2):
  bpf: make bpf_def.h private
  bpf: rename macros to match Linux kernel

 app/test/test_bpf.c              | 1685 +++++++++++++++---------------
 app/test/test_bpf_validate.c     |  268 ++---
 lib/bpf/bpf_convert.c            |   78 +-
 lib/bpf/bpf_def.h                |   91 +-
 lib/bpf/bpf_dump.c               |   45 +-
 lib/bpf/bpf_exec.c               |  156 +--
 lib/bpf/bpf_impl.h               |    5 +-
 lib/bpf/bpf_jit_arm64.c          |  218 ++--
 lib/bpf/bpf_jit_x86.c            |  312 +++---
 lib/bpf/bpf_load.c               |    2 +-
 lib/bpf/bpf_load_elf.c           |   24 +-
 lib/bpf/bpf_validate.c           |  310 +++---
 lib/bpf/bpf_validate.h           |    4 +-
 lib/bpf/bpf_validate_debug.c     |    6 +-
 lib/bpf/meson.build              |    2 +-
 lib/bpf/rte_bpf.h                |   35 +-
 lib/bpf/rte_bpf_validate_debug.h |    8 +-
 17 files changed, 1623 insertions(+), 1626 deletions(-)

-- 
2.43.0
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.