Re: [PATCH v2 0/2] drm/ttm: two small ttm_bo.c cleanups

Christian König <[email protected]>
Newsgroups org.freedesktop.lists.dri-devel,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On 8/18/26 18:37, Sean Chang wrote:
> This series contains two independent, minor cleanups to
> drivers/gpu/drm/ttm/ttm_bo.c found while auditing the file. They do
> not depend on each other and could be applied in either order or
> separately.
> 
> Patch 1 removes a stale @ctx kernel-doc entry left over from an
> earlier struct change, fixing a kernel-doc / W=1 mismatch warning.
> 
> Patch 2 gives ttm_swap_ops static linkage since it is not used
> outside this file and is not exported, fixing a sparse
> "was not declared, should it be static?" warning.
> 
> Both patches were build-tested with make W=1 C=2.
> 
> ---
> v2:
>  - Correct target function name in patch 1 commit message to
>    ttm_bo_alloc_at_place.

I haven't seen v2 in my inbox for some reason before pushing v1.

So the name is wrong in the commit message, but that shouldn't really hurt.

Anyway patches have been pushed to drm-misc-next.

Thanks,
Christian.

> 
> Sean Chang (2):
>   drm/ttm: drop stale @ctx kernel-doc entry
>   drm/ttm: make ttm_swap_ops static
> 
>  drivers/gpu/drm/ttm/ttm_bo.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> --
> 2.43.0
>
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.