Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle docs after move_notify() rename
| Newsgroups | org.freedesktop.lists.dri-devel,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
> From: Leon Romanovsky <[email protected]> > > Commit 95308225e5ba ("dma-buf: Rename dma_buf_move_notify() to > dma_buf_invalidate_mappings()") left the DMABUF section of the P2PDMA > documentation pointing at move_notify(), a symbol that no longer > exists. Readers grepping for it find nothing, and this is the only > place in Documentation/ describing the revocation requirement. > > Name the current function and record that importers which cannot unmap > within bounded time have to be rejected at attach time, which is what > makes the synchronous unmap on remove() achievable. > > Fixes: 95308225e5ba ("dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()") > Signed-off-by: Leon Romanovsky <[email protected]> Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=1