[PATCH v6 0/2] drm/xe/sysctrl: Add helpers to query application
"Anoop, Vijay" <[email protected]>
| Newsgroups | org.freedesktop.lists.intel-xe |
|---|---|
| Message-ID | <[email protected]> |
From: Anoop Vijay <[email protected]> This series adds helpers to query the readiness state of individual System Controller (sysctrl) firmware applications via the get_app_status_by_id mailbox command. xe_sysctrl_check_app_status() maps an xe_sysctrl_app_id to its firmware application identifier and returns the reported application state: not supported, communication failure, booted, or fully initialized. Convenience wrappers are added on top of this helper to check readiness of the Diagnostics (diag) and oCode firmware applications. The initial consumers of these wrappers are added in the series https://patchwork.freedesktop.org/series/171728/ --- v2: (Badal) - Return SysCtrl firmware application states instead of errno for application lifecycle conditions v3: (Riana, Badal) - Replace string-based app identifiers with enum xe_sysctrl_app_id - Use get_app_status_by_id (opcode 0x05) - Move mailbox definitions to xe_sysctrl_mailbox_types.h - Return enum xe_sysctrl_fw_status consistently - Map communication failures to COMM_FAILURE - Add INITIALIZED state and status helpers - Fix Diagnostics typo v4: (Anshuman) - Make xe_sysctrl_check_app_status() internal - Remove unused app identifier v5: (Anshuman) - Rename OOBMSM status helper to use xe_sysctrl_* prefix - Remove xe_is_diag_fw_ready() helper v6: (Riana) - Use xe_sysctrl_create_command() helper instead of manual FIELD_PREP header packing - Rename xe_sysctrl_get_app_status_by_id_{req,resp} to shorter names - Use hex constant for application ID - Split oCode application readiness helper into its own patch - Add xe_sysctrl_is_diag_fw_ready() helper; consumer lands in the RAS error-injection series --- Anoop Vijay (2): drm/xe/sysctrl: Add helper to query application status drm/xe/sysctrl: Add helper to check oCode firmware readiness drivers/gpu/drm/xe/xe_sysctrl.c | 82 +++++++++++++++++++ drivers/gpu/drm/xe/xe_sysctrl.h | 2 + drivers/gpu/drm/xe/xe_sysctrl_mailbox_types.h | 65 +++++++++++++++ 3 files changed, 149 insertions(+) -- 2.43.0