Re: [PATCH] bcma,ssb: simplify dependency handling for bcma and ssb drivers

Kalle Valo <[email protected]> Mon, 18 Dec 2023 16:59:00 +0200
Newsgroups org.infradead.lists.b43-dev,org.kernel.vger.kernel-janitors,org.kernel.vger.linux-kernel,org.kernel.vger.linux-wireless,org.kernel.vger.netdev
Message-ID <[email protected]>
Johannes Berg <[email protected]> writes:

> On Mon, 2023-12-18 at 12:58 +0100, Lukas Bulwahn wrote:
>
> Dunno, I'm not super involved with this but ...
>
>> +++ b/drivers/bcma/Kconfig
>> @@ -1,12 +1,7 @@
>>  # SPDX-License-Identifier: GPL-2.0
>> -config BCMA_POSSIBLE
>> -	bool
>> -	depends on HAS_IOMEM && HAS_DMA
>> -	default y
>> -
>>  menuconfig BCMA
>>  	tristate "Broadcom specific AMBA"
>> -	depends on BCMA_POSSIBLE
>> +	depends on HAS_IOMEM && HAS_DMA
>
> [...]
>>  config BRCMSMAC
>>  	tristate "Broadcom IEEE802.11n PCIe SoftMAC WLAN driver"
>> -	depends on MAC80211
>> -	depends on BCMA_POSSIBLE
>> +	depends on HAS_IOMEM && HAS_DMA && MAC80211
>>  	select BCMA
>
> to me it kind of seems more obvious for example in this case to say
> "depend on BCMA_POSSIBLE and select BCMA" rather than open-coding the
> BCMA dependencies both here and in BCMA? Now granted, they're rather
> unlikely to _change_, but it still seems more obvious?

I was thinking the same. Lukas, is there a specific reason why you want
to change this or this just something you noticed by chance?

-- 
https://patchwork.kernel.org/project/linux-wireless/list/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

_______________________________________________
b43-dev mailing list
[email protected]
http://lists.infradead.org/mailman/listinfo/b43-dev