Re: [PATCH v7 07/12] PCI: Refactor matching logic for pci_dev_acs_ops
Pasha Tatashin <[email protected]> Fri, 17 Jul 2026 22:02:35 +0000
| Newsgroups | org.infradead.lists.kexec,org.kernel.vger.linux-doc,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci,org.kvack.linux-mm |
|---|---|
| Message-ID | <178432575544.189683.9290455764634301119.b4-review@b4> |
On Fri, 10 Jul 2026 21:26:10 +0000, David Matlack <[email protected]> wrote: > Refactor the logic to match devices to pci_dev_acs_ops by factoring out > the loop and device matching into its own routine. This eliminates some > duplicate code between pci_dev_specific_enable_acs() and > pci_dev_specific_disable_acs_redir(), and will also be used in a > subsequent commit to check if a device requires device-specific > enable_acs() during a Live Update. > > [...] Reviewed-by: Pasha Tatashin <[email protected]> -- Pasha Tatashin <[email protected]>