Re: [PATCH v10 1/3] dt-bindings: dma: Add Amlogic A9 SoC DMA
| Newsgroups | org.infradead.lists.linux-amlogic,org.kernel.vger.dmaengine,org.kernel.vger.linux-devicetree |
|---|---|
| Message-ID | <[email protected]> |
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] The macros DMA_TX and DMA_RX in the global devicetree bindings header lack an SoC or vendor prefix, causing namespace pollution. -- --- Patch [1]: [PATCH v10 1/3] dt-bindings: dma: Add Amlogic A9 SoC DMA --- commit dd68c09cf89a4142756eff7b44b06fb8f8ed1b20 Author: Xianwei Zhao <[email protected]> dt-bindings: dma: Add Amlogic A9 SoC DMA This commit adds documentation describing the Amlogic A9 SoC DMA controller. It also introduces a new include file containing specific property values for DMA channels. [ ... ] > diff --git a/include/dt-bindings/dma/amlogic,a9-dma.h b/include/dt-bindings/dma/amlogic,a9-dma.h > new file mode 100644 > index 0000000000000..c59c2fd4b9561 > --- /dev/null > +++ b/include/dt-bindings/dma/amlogic,a9-dma.h > @@ -0,0 +1,8 @@ > +/* SPDX-License-Identifier: (GPL-2.0 OR MIT) */ > + > +#ifndef __DT_BINDINGS_DMA_AMLOGIC_DMA_H__ > +#define __DT_BINDINGS_DMA_AMLOGIC_DMA_H__ > + > +#define DMA_TX 0 > +#define DMA_RX 1 [Severity: Low] Do these macro names need a vendor or SoC prefix like AMLOGIC_A9_DMA_TX? Since they are in a global devicetree bindings header, using generic names like DMA_TX and DMA_RX could pollute the global macro namespace. Are these likely to collide with existing definitions in other driver headers and cause macro redefinition build errors? > +#endif /* __DT_BINDINGS_DMA_AMLOGIC_DMA_H__ */ -- Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=1 _______________________________________________ linux-amlogic mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-amlogic