Re: [PATCH v9 2/6] mfd: khadas-mcu: Use MFD_CELL_* macros for cell declarations
| Newsgroups | org.infradead.lists.linux-amlogic,dev.linux.lists.mfd,org.kernel.vger.linux-devicetree |
|---|---|
| Message-ID | <[email protected]> |
> From: Ronald Claveau <[email protected]> > > Convert khadas_mcu_fan_cells[] and khadas_mcu_cells[] to use the > MFD_CELL_NAME() helper macro instead of open-coding the struct > mfd_cell initialisers. While at it, make both arrays const since > they are never modified after initialisation. > > This is a pure cleanup with no functional change, done in > preparation for a subsequent patch which will need to attach > platform_data to the fan cell. > > Signed-off-by: Ronald Claveau <[email protected]> Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=2 _______________________________________________ linux-amlogic mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-amlogic