Re: [PATCH v3 2/8] dt-bindings: gpio: cdns: add Axiado AX3005 GPIO variant
Krzysztof Kozlowski <[email protected]> Fri, 17 Jul 2026 10:33:06 +0200
| Newsgroups | org.infradead.lists.linux-i3c,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-gpio,org.kernel.vger.linux-i2c,org.kernel.vger.linux-kernel,org.kernel.vger.linux-serial,org.kernel.vger.linux-spi,org.kernel.vger.linux-usb |
|---|---|
| Message-ID | <20260717-prudent-indefinable-labradoodle-fcaa9e@quoll> |
On Thu, Jul 16, 2026 at 08:51:09PM -0700, Swark Yang wrote: > Add binding for Axiado AX3005 GPIO controller. So far, no changes > are known, so it can fall back to the cdns,gpio-r1p02 compatible. > > Signed-off-by: Swark Yang <[email protected]> > --- > Documentation/devicetree/bindings/gpio/cdns,gpio.yaml | 7 +++++-- > 1 file changed, 5 insertions(+), 2 deletions(-) > > diff --git a/Documentation/devicetree/bindings/gpio/cdns,gpio.yaml b/Documentation/devicetree/bindings/gpio/cdns,gpio.yaml > index a84d60b39459..7eacf5af6554 100644 > --- a/Documentation/devicetree/bindings/gpio/cdns,gpio.yaml > +++ b/Documentation/devicetree/bindings/gpio/cdns,gpio.yaml > @@ -14,8 +14,11 @@ properties: > oneOf: > - const: cdns,gpio-r1p02 > - items: > - - enum: This should stay enum which would also make your diff easier to read. Acked-by: Krzysztof Kozlowski <[email protected]> Best regards, Krzysztof -- linux-i3c mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-i3c