[PATCH v9 00/36] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
Mikhail Kshevetskiy <[email protected]> Tue, 4 Aug 2026 19:03:43 +0300
| Newsgroups | org.infradead.lists.linux-mediatek,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-gpio,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
This patchset * fixes more airoha pinctrl issues * split combined driver on common code and several SoC specific drivers * improves an7583 pinctrl support * adds support of en7523 SoC * adds support of an7563 SoC The driver split changes are based on Matheus Sampaio Queiroga work. Changes v2: * more issues of airoha pinctrl driver was fixed * SoC specific register addresses, bitfields, macroses were removed from common header and placed to SoC specific file * fixed address of LAN LED mappings registers for en7523 SoC * improves support of an7583 pinctrl Changes v3: * improve searching of chip scu regmap necessary for drivers operations Changes v4: * an7583: add support of OLT pin function * an7581: do a proper fix of pcie_reset pins mux/conf. Changes v5: * improve description of an7583 i2c pinmux fix * rename an7583 registers to match its an7583 names * add support of an7563 SoC Changes v6: * fix some of the issues found by https://sashiko.dev/#/patchset/20260622113046.3619139-1-mikhail.kshevetskiy%40iopsys.eu * update device tree binding * add bindings for en7523 and an7563 Changes v7: * a lot of IRQ support fixes, now there is chances that IRQ code is really working * device tree bindings moved to the separate patches * fix some of the issues found by https://sashiko.dev/#/patchset/[email protected] Changes v8: * an7581: fix pinconf of i2c_scl/i2c_sda pins * ignore high bit in set_direction/get_direction helpers * minor patch modification * fix some issue found by https://sashiko.dev/#/patchset/[email protected] * add more 'Fixes: commit' lines * add Acked-by Lorenzo Bianconi where it was approved Changes v9: * fix some issue found by https://sashiko.dev/#/message/20260727174141.664933-5-mikhail.kshevetskiy%40iopsys.eu * take into account openwrt changes created by Daniel Schwierzeck * improve binding patches Daniel Schwierzeck (3): pinctrl: airoha: fix I2C1 pin mux config for AN7581 pinctrl: airoha: fix I2C pin mux config for AN7583 pinctrl: airoha: fix AN7583 MDIO pin mux config Mikhail Kshevetskiy (33): dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema pinctrl: airoha: fix mdio bitfield names pinctrl: airoha: an7581: fix pinconf of i2c_scl/i2c_sda pins pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm pinctrl: airoha: an7583: fix muxing of non-gpio default pins dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm pinctrl: airoha: an7583: fix spi group pins pinctrl: airoha: add missed get_direction() function for gpio_chip pinctrl: airoha: add set_direction() helper for gpio_chip pinctrl: airoha: minor improvements pinctrl: airoha: fix getting gpiochip/pinctrl pointers in the IRQ handling code pinctrl: airoha: add missed IRQ resource helpers pinctrl: airoha: fix IRQ mask/unmask code pinctrl: airoha: fix edge-triggered interrupts handling pinctrl: airoha: remove not needed irq_type[] array pinctrl: airoha: statically allocate gpio regs structure pinctrl: airoha: move common definitions to the separate header pinctrl: airoha: split driver on shared code and SoC specific drivers pinctrl: airoha: an7581: remove en7581 prefix from variable names pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions pinctrl: airoha: an7583: rename registers to match its an7583 names pinctrl: airoha: an7583: add support for npu_uart pinmux pinctrl: airoha: an7583: add support for pon_alt pinmux pinctrl: airoha: an7583: add support for olt pinmux dt-bindings: pinctrl: airoha: an7583: add missed features pinctrl: airoha: add support of en7523 SoC pinctrl: airoha: try to find chip scu node by phandle first dt-bindings: pinctrl: airoha: add support of en7523 pin controller pinctrl: airoha: add support of an7563 SoC dt-bindings: pinctrl: airoha: add support of an7563 pin controller .../pinctrl/airoha,an7563-pinctrl.yaml | 348 +++ .../pinctrl/airoha,an7583-pinctrl.yaml | 59 +- .../pinctrl/airoha,en7523-pinctrl.yaml | 379 +++ .../pinctrl/airoha,en7581-pinctrl.yaml | 15 +- drivers/pinctrl/airoha/Kconfig | 42 +- drivers/pinctrl/airoha/Makefile | 7 + drivers/pinctrl/airoha/airoha-common.h | 147 + drivers/pinctrl/airoha/pinctrl-airoha.c | 2645 ++--------------- drivers/pinctrl/airoha/pinctrl-an7563.c | 1115 +++++++ drivers/pinctrl/airoha/pinctrl-an7581.c | 1487 +++++++++ drivers/pinctrl/airoha/pinctrl-an7583.c | 1517 ++++++++++ drivers/pinctrl/airoha/pinctrl-en7523.c | 1157 +++++++ 12 files changed, 6440 insertions(+), 2478 deletions(-) create mode 100644 Documentation/devicetree/bindings/pinctrl/airoha,an7563-pinctrl.yaml create mode 100644 Documentation/devicetree/bindings/pinctrl/airoha,en7523-pinctrl.yaml create mode 100644 drivers/pinctrl/airoha/airoha-common.h create mode 100644 drivers/pinctrl/airoha/pinctrl-an7563.c create mode 100644 drivers/pinctrl/airoha/pinctrl-an7581.c create mode 100644 drivers/pinctrl/airoha/pinctrl-an7583.c create mode 100644 drivers/pinctrl/airoha/pinctrl-en7523.c -- 2.53.0