Re: [PATCH] pinctrl: Use IRQ trigger mask helpers
Linus Walleij <[email protected]> Thu, 6 Aug 2026 23:41:24 +0200
| Newsgroups | org.infradead.lists.linux-mediatek,dev.linux.lists.soc,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-gpio,org.kernel.vger.linux-kernel,org.ozlabs.lists.openbmc |
|---|---|
| Message-ID | <CAD++jLm+sfo2pB=cM3v2-ewwdkaomRvTdKh9VVKNU8mJS3wPyA@mail.gmail.com> |
On Sun, Aug 2, 2026 at 4:06 PM Maulik Shah <[email protected]> wrote: > Use IRQ_TYPE_LEVEL_MASK and IRQ_TYPE_EDGE_BOTH instead of open-coded > trigger type combinations in irqchip callbacks. > > No functional change intended. > > Assisted-by: Claude:claude-sonnet-5 > Signed-off-by: Maulik Shah <[email protected]> Nice cleanup, patch applied! Yours, Linus Walleij