Re: [PATCH v8 03/39] drm/display: bridge_connector: Pass HDMI capabilities through caps struct
Cristian Ciocaltea <[email protected]>
| Newsgroups | org.infradead.lists.linux-rockchip,org.freedesktop.lists.dri-devel,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On 7/22/26 9:47 AM, Dmitry Baryshkov wrote: > On Wed, Jul 08, 2026 at 01:19:23PM +0300, Cristian Ciocaltea wrote: >> On 7/8/26 9:46 AM, Maxime Ripard wrote: >>> On Fri, Jul 03, 2026 at 10:55:09PM +0300, Cristian Ciocaltea wrote: >>>> On 7/3/26 5:19 PM, Dmitry Baryshkov wrote: >>>>> On Thu, Jul 02, 2026 at 05:46:16PM +0300, Cristian Ciocaltea wrote: >>>>>> Switch drm_bridge_connector_init() to >>>>>> drmm_connector_hdmi_init_with_caps(), collecting the bridge's HDMI >>>>>> properties into a stack drm_connector_hdmi_caps so future HDMI 2.x >>>>>> capabilities can be plumbed without growing the argument list. >>>>>> >>>>>> Introduce struct drm_bridge::supported_hdmi_ver to let bridges declare >>>>>> the HDMI specification version they are conformant with, and forward it >>>>>> to the connector layer through the new caps struct so HDMI 2.x features >>>>>> can be gated on real source capability rather than guesswork. >>>>> >>>>> And it's left uninitialized by the bridges, which doesn't mean anything. >>>>> If you don't want to touch all bridge drivers in one commit, please >>>>> provide some migration path and hopefully get rid of it by the end of >>>>> the series. >>>> >>>> Sure, one question though: at the end of the migration, would it be fine to >>>> stick with drmm_connector_hdmi_init_with_caps() and just drop >>>> drmm_connector_hdmi_init()? Otherwise I'll rename it back. >>> >>> Absolutely, it doesn't make any sense to keep both variants. >> >> I was referring to whether option 3 might be the preferred choice in the context >> of the earlier patch discussion. > > Plesae exuse my ignorance, what is option 3? The options discussed were: 1. Continue with drmm_connector_hdmi_init_with_caps() after removing the caps parameter, and then drop drmm_connector_hdmi_init() after the migration. ... 3. A variation of option 1: additionally rename drmm_connector_hdmi_init_with_caps() to drmm_connector_hdmi_init() after the migration. In the end I went with a slightly different approach: temporarily renamed the original helper to drmm_connector_hdmi_ini2(), to let the new signature be introduced under the original name while callers were converted incrementally. Finally added a patch to remove *_ini2(). Note the transitional name had the same length, to avoid re-alignment churn and keep the diffs to a minimum. Cristian _______________________________________________ Linux-rockchip mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-rockchip