[PATCH 1/3] platform: generic: spacemit: k1: rename cache flush operation
Troy Mitchell <[email protected]> Fri, 24 Jul 2026 02:27:01 -0700
| Newsgroups | org.infradead.lists.opensbi |
|---|---|
| Message-ID | <[email protected]> |
From: Xianbin Zhu <[email protected]> MRAOP_ICACHE_INVALID is used to flush the local D-cache before a hart stops, so the name incorrectly describes I-cache invalidation. Rename it to MRAOP_CACHE_FLUSH without changing its encoded value. Signed-off-by: Xianbin Zhu <[email protected]> Co-developed-by: Troy Mitchell <[email protected]> Signed-off-by: Troy Mitchell <[email protected]> --- lib/utils/hsm/fdt_hsm_spacemit.c | 2 +- platform/generic/include/spacemit/k1.h | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/lib/utils/hsm/fdt_hsm_spacemit.c b/lib/utils/hsm/fdt_hsm_spacemit.c index 868e49bf..99c52335 100644 --- a/lib/utils/hsm/fdt_hsm_spacemit.c +++ b/lib/utils/hsm/fdt_hsm_spacemit.c @@ -92,7 +92,7 @@ static int spacemit_hart_stop(void) asm volatile ("fence iorw, iorw"); /* flush local dcache */ - csr_write(CSR_MRAOP, MRAOP_ICACHE_INVALID); + csr_write(CSR_MRAOP, MRAOP_CACHE_FLUSH); asm volatile ("fence iorw, iorw"); /* disable dcache */ diff --git a/platform/generic/include/spacemit/k1.h b/platform/generic/include/spacemit/k1.h index 7095bc08..ac727b04 100644 --- a/platform/generic/include/spacemit/k1.h +++ b/platform/generic/include/spacemit/k1.h @@ -20,8 +20,8 @@ /* ECC enable */ #define MSETUP_ECCE BIT(16) -/* icache invalidation */ -#define MRAOP_ICACHE_INVALID GENMASK(1, 0) +/* cache flush */ +#define MRAOP_CACHE_FLUSH GENMASK(1, 0) #define PMU_AP_BASE 0xd4282800 -- 2.55.0 -- opensbi mailing list [email protected] http://lists.infradead.org/mailman/listinfo/opensbi