[PATCH 0/6] PCI/pwrctrl: tc9563: Several fixes and improvements
Manivannan Sadhasivam <[email protected]>
| Newsgroups | org.kernel.feeds.b4-sent,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
Hi, This series contains several fixes and improvements for the TC9563 Pwrctrl driver and the switch binding. Most of the fixes are related to ensuring correctness in parsing the DT properties for the switch ports and the integrated Endpoint. More details are in the individual patches. Testing ======= This series was validated on the RB3Gen2 board. Signed-off-by: Manivannan Sadhasivam <[email protected]> --- Manivannan Sadhasivam (6): dt-bindings: PCI: toshiba,tc9563: Restrict Tx Amplitude, DFE and N_FTS to USP, DSP1 and DSP2 PCI/pwrctrl: tc9563: Fix parsing the integrated Ethernet MAC Endpoint node PCI/pwrctrl: tc9563: Power off only the external ports in tc9563_pwrctrl_disable_port() PCI/pwrctrl: tc9563: Skip Tx amplitude and DFE tuning for DSP3 PCI/pwrctrl: tc9563: Rename DSP3 to VDSP PCI/pwrctrl: tc9563: Move Integrated MAC Endpoint out of 'tc9563_pwrctrl_ports' enum .../devicetree/bindings/pci/toshiba,tc9563.yaml | 21 +++- drivers/pci/pwrctrl/pci-pwrctrl-tc9563.c | 129 ++++++++++++++------- 2 files changed, 104 insertions(+), 46 deletions(-) --- base-commit: dc59e4fea9d83f03bad6bddf3fa2e52491777482 change-id: 20260725-tc9563-fix-64eb7cbb1229 Best regards, -- மணிவண்ணன் சதாசிவம்