[PATCH 0/2] ata: use named initializers for acpi_device_id
"Pawel Zalewski (The Capable Hub)" <[email protected]> Mon, 03 Aug 2026 16:03:49 +0100
| Newsgroups | org.kernel.feeds.b4-sent,org.kernel.vger.linux-ide,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
This series is converting lists that contain the acpi_device_id
struct, which is defined in the include/linux/device-id/acpi.h
to makes use of named initializers (which they do not use currently).
This work is part of the on going effort in the kernel associated
with device-ids [1]
The plan is to convert acpi_device_id::driver_data to have an anonymous
union, similarly to what was introduced for PCI and I2C device ID tables.
The goal is to increase type-safety (as most of the existing casts are gone),
to improve readability and to make use intent a bit more clear:
```
union {
kernel_ulong_t driver_data;
const void *driver_data_ptr;
}
```
But for that to work all lists containing the structs need to use named
initializers first. I already have patches that implement this and touching
a lot of kernel subsystmes that use the acpi_device_id struct and that list
keeps on growing. Therefore, I have decided to split the series per every
subsystem into:
- pre-clean-ups that convert the lists to use named initializers (this series)
- actual implementations that make some of the modules use the new driver_data_ptr
That way the task can be fragmented into manageable and independent
chunks of work and makes this effort easier to review.
Tested builds on x86-64 in Yocto using 7.2-rc6
Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]>
---
Pawel Zalewski (The Capable Hub) (2):
ata: use named initializers for acpi_device_id
ata: ahci_seattle: drop unused acpi_device_id::driver_data
drivers/ata/ahci_platform.c | 4 ++--
drivers/ata/ahci_qoriq.c | 2 +-
drivers/ata/ahci_seattle.c | 4 ++--
drivers/ata/ahci_xgene.c | 6 +++---
4 files changed, 8 insertions(+), 8 deletions(-)
---
base-commit: 9ecfb2f7287a967b418ba69f10d45ead0d360593
change-id: 20260803-ata-acpi-18f405eb03a2
Best regards,
--
Pawel Zalewski (The Capable Hub) <[email protected]>