[MODERATED] Re: [PATCH 2/2] more sampling fun 2

Borislav Petkov <[email protected]> Tue, 25 Feb 2020 11:46:58 +0100
Newsgroups org.kernel.lore.historical-speck
Message-ID <[email protected]>
On Mon, Feb 24, 2020 at 07:26:41PM -0600, speck for Josh Poimboeuf wrote:
> Why not just srbds= ?  That's what Intel calls it, and it would be
> consistent with some of the other options like mds= and l1tf=.

For the same reason we did "spec_store_bypass_disable=" and not "ssbd=".
Although former is a bit longish for my taste, it doesn't make you go
look it up as "ssbd" does. And with "mds" and "l1tf" we dropped the ball
again. :-\

Over time, they would all become a letters jumble which we all would
have to go look up.

So I think at least *trying* to make them a bit more
understandable/parseable for humans, would be beneficial in the long
run.

So, for example, when I see "srb_sampling=off" at least I know, oh, ok,
it disables sampling of that SRB thing. "srbds" tells me exactly nothing
and the potential for flipping those letters' position is high.

-- 
Regards/Gruss,
    Boris.

SUSE Software Solutions Germany GmbH, GF: Felix Imendörffer, HRB 36809, AG Nürnberg
--