[MODERATED] Re: [PATCH 2/2] more sampling fun 2

Josh Poimboeuf <[email protected]> Wed, 26 Feb 2020 14:20:10 -0600
Newsgroups org.kernel.lore.historical-speck
Message-ID <20200226202010.k42cf4625ckk6ym6@treble>
On Tue, Feb 25, 2020 at 03:59:06PM +0100, speck for Borislav Petkov wrote:
> > I'd expect to call this one "SRBDS" a year from now. I find
> > "srb_sampling" to be confusing and hard to remember because it renames
> > something that already has an industry standard name.
> 
> srb_sampling *is* srbds - just more readable.
> 
> We are not giving any new names to the vulns - we're simply making our command
> line options more readable so that when you have to type them, you either have
> to remember "srbds" - in that order - or "srb sampling".
> 
> Latter is easier for me.

But you're leaving out the "data" portion of the acronym/name.

Either call it "srbds" or "special_register_buffer_data_sampling" -- but
*please* don't give it a new name.  It will just create more confusion.

If you can't remember what srbds stands for, that's why we have
documentation and search engines.

-- 
Josh