[MODERATED] Re: [PATCH 2/2] more sampling fun 2
Borislav Petkov <[email protected]> Tue, 25 Feb 2020 15:59:06 +0100
| Newsgroups | org.kernel.lore.historical-speck |
|---|---|
| Message-ID | <[email protected]> |
On Tue, Feb 25, 2020 at 08:18:52AM -0600, speck for Josh Poimboeuf wrote:
> Well, I see it the opposite way. Those jumbles of letters do actually
> mean something. I still call them "MDS", "L1TF", "SSBD". If you google
> for "l1tf" or "mds vulnerability" they show up.
If I gurgle "spec store bypass" it gets me straight to the wikipedia page:
"Speculative Store Bypass (SSB) (CVE-2018-3639) is the name... "
> I'd expect to call this one "SRBDS" a year from now. I find
> "srb_sampling" to be confusing and hard to remember because it renames
> something that already has an industry standard name.
srb_sampling *is* srbds - just more readable.
We are not giving any new names to the vulns - we're simply making our command
line options more readable so that when you have to type them, you either have
to remember "srbds" - in that order - or "srb sampling".
Latter is easier for me.
And yes, spec_store_bypass_disable= should've been
spec_store_bypass=<switches...>
--
Regards/Gruss,
Boris.
SUSE Software Solutions Germany GmbH, GF: Felix Imendörffer, HRB 36809, AG Nürnberg
--