Re: [PATCH 0/5] Slow Randomizing Boosts DoS v4.4.219 backport 0
Thomas Gleixner <[email protected]> Mon, 27 Apr 2020 21:47:11 +0200
| Newsgroups | org.kernel.lore.historical-speck |
|---|---|
| Message-ID | <[email protected]> |
Thomas Gleixner <[email protected]> writes: > speck for mark gross <[email protected]> writes: >> From: mark gross <[email protected]> >> Subject: [PATCH 0/5] Slow Ranomizing Boosts DoS linux-4.4.y backport >> >> This is a backport of the backports done by Thomas for linux-4.14.y to >> linux-4.4.y. >> >> The backport needed a backport of one additional dependency for >> cpu_data-x86_mask getting renamed to x86_stepping. >> >> This was tested by the test engineer who tested the other SRBDS implementations >> and it seems to work. >> >> >> Jia Zhang (1): >> x86/cpu: Rename cpu_data.x86_mask to cpu_data.x86_stepping > > This one is missing and rightfully so. Maybe you get your mail setup for > sending patches right some day in the future. > > This one has in the mail headers: > > In-Reply-To: <[email protected]> > References: <[email protected]> > From: Jia Zhang <[email protected]> > Date: Mon, 1 Jan 2018 09:52:10 +0800 > > While it's correct that the patch is from Jia and was written on Jan. 1 > 2018, neither the From: nor the Date: header in the mail are correct. > > That's commit b399151cb48db30ad1e0e93dd40d68c6d007b637 upstream. Do we > really want to backport that thing to 4.4 or just live with the uglies > of x86_cpuinfo::x86_mask ? Fished it out from the moderator mail, applied it to 4.4.y and then ran: # git grep 'x86_mask' arch/x86/kernel/cpu/amd.c: if (c->x86_model <= 1 && c->x86_mask <= 1) I clearly can see how that was tested. Thanks, tglx