Re: [PATCH] audit: use copied skb le ngth in kauditd_send_multicast_skb()
Bradley Morgan <[email protected]>
| Newsgroups | org.kernel.vger.audit,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Hi Ricardo, > - nlh->nlmsg_len = skb->len; > + nlh->nlmsg_len = copy->len; Fine. skb_copy() does skb_put(n, skb->len) and nothing touches copy->len in between, so the two are always identical. Which is also why "safer" is a bit of a stretch, it prevents nothing. Feel free to bikeshed the changelog wording on that. If you ever want a more interesting cleanup here, the real quirk is the line above: the unicast path sets nlmsg_len to skb->len minus NLMSG_HDRLEN, this one uses the full length. Well, why not, please add: Reviewed-by: Bradley Morgan <[email protected]> Thanks!