[PATCH 10/30] header: Rename kfree_sensitive(x) to kzfree(x)

Hauke Mehrtens <[email protected]>
Newsgroups org.kernel.vger.backports
Message-ID <[email protected]>
This was added in upstream Linux commit 453431a54934 ("mm, treewide:
rename kzfree() to kfree_sensitive()").

Signed-off-by: Hauke Mehrtens <[email protected]>
---
 backport/backport-include/linux/slab.h | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/backport/backport-include/linux/slab.h b/backport/backport-include/linux/slab.h
index 66f0cc0d..f36dc40a 100644
--- a/backport/backport-include/linux/slab.h
+++ b/backport/backport-include/linux/slab.h
@@ -24,4 +24,8 @@ static inline void *kmalloc_array(size_t n, size_t size, gfp_t flags)
 }
 #endif
 
+#if LINUX_VERSION_IS_LESS(5,9,0)
+#define kfree_sensitive(x)	kzfree(x)
+#endif
+
 #endif /* __BACKPORT_SLAB_H */
-- 
2.20.1

--
To unsubscribe from this list: send the line "unsubscribe backports" in
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.