Re: [PATCH bpf-next v5 0/6] bpf: Inline the numeric open-coded iterator kfuncs
[email protected] Wed, 05 Aug 2026 17:50:14 +0000
| Newsgroups | org.kernel.vger.bpf |
|---|---|
| Message-ID | <178595221439.468918.12755390994472161307.git-patchwork-notify@kernel.org> |
Hello: This series was applied to bpf/bpf-next.git (master) by Andrii Nakryiko <[email protected]>: On Tue, 4 Aug 2026 06:45:52 -0700 you wrote: > The bpf_for(i, start, end) macro is BPF's open-coded numeric iterator. It > expands into calls to three kfuncs: bpf_iter_num_new() to set the iterator > up, bpf_iter_num_next() once per iteration, and bpf_iter_num_destroy() to > tear it down. The verifier emits these as ordinary kfunc calls, so a > bpf_for() loop pays function-call overhead on setup, teardown, and -- most > importantly -- on every single iteration via bpf_iter_num_next(). > > [...] Here is the summary with links: - [bpf-next,v5,1/6] bpf: Correct the overflow check comment in bpf_iter_num_next() https://git.kernel.org/bpf/bpf-next/c/8efd87051c3a - [bpf-next,v5,2/6] bpf: Inline bpf_iter_num_new() kfunc https://git.kernel.org/bpf/bpf-next/c/f8f2b567d560 - [bpf-next,v5,3/6] bpf: Inline bpf_iter_num_next() kfunc https://git.kernel.org/bpf/bpf-next/c/e93347704878 - [bpf-next,v5,4/6] bpf: Inline bpf_iter_num_destroy() as a no-op https://git.kernel.org/bpf/bpf-next/c/39f047682fe3 - [bpf-next,v5,5/6] selftests/bpf: Verify inlined numeric iterator shape with __xlated https://git.kernel.org/bpf/bpf-next/c/b829bc167705 - [bpf-next,v5,6/6] selftests/bpf: Add bpf_for() benchmark https://git.kernel.org/bpf/bpf-next/c/5a1de41147b0 You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html