Re: [RFC PATCH bpf-next v5 3/8] selftests/bpf: factor the permissive-mode skip suffix into a helper
Eduard Zingerman <[email protected]>
| Newsgroups | org.kernel.vger.bpf |
|---|---|
| Message-ID | <[email protected]> |
On Tue, 2026-08-04 at 10:01 -0700, Mykola Lysenko wrote:
> With BPF_STRICT_BUILD=0, eleven recipes append the same "|| { remove
> the target, print a SKIP marker, report success }" tail, each spelled
> out inline. Factor the tail into skip_on_fail, parameterized by the
> SKIP tag, optional extra files to remove alongside the target and an
> optional note appended to the message - every call site keeps its
> exact message and behavior.
>
> The permissive fragments of other shapes are not suffixes and keep
> their current form: the rsync --ignore-missing-args flags, the
> missing-input guards in the skeleton recipes, the link rule's
> wildcard handling and the test_kmods copy wrapper.
>
> Signed-off-by: Mykola Lysenko <[email protected]>
> ---
Acked-by: Eduard Zingerman <[email protected]>
...