Re: [PATCH bpf-next v2 6/6] docs, resolve_btfids: Document kfunc BTF annotation emission
Ihor Solodrai <[email protected]>
| Newsgroups | org.kernel.vger.bpf |
|---|---|
| Message-ID | <[email protected]> |
On 8/5/26 5:01 PM, [email protected] wrote: >> diff --git a/Documentation/bpf/kfuncs.rst b/Documentation/bpf/kfuncs.rst >> index cbde86d082cce..c60fc574e8b06 100644 >> --- a/Documentation/bpf/kfuncs.rst >> +++ b/Documentation/bpf/kfuncs.rst >> @@ -472,6 +472,14 @@ type. An example is shown below:: >> } >> late_initcall(init_subsystem); >> >> +At kernel build time the ``resolve_btfids`` tool discovers all kfuncs from the >> +registered ``BTF_SET8_KFUNCS`` sets and emits their BTF annotations into the >> +kernel's BTF; these annotations were historically produced by pahole. For each >> +discovered kfunc ``resolve_btfids`` emits a ``bpf_kfunc`` BTF decl tag, a >> +``bpf_fastcall`` decl tag when the kfunc is flagged ``KF_FASTCALL``, and the >> +``address_space(1)`` type attribute on the return value and/or arguments flagged >> +``KF_ARENA_RET``, ``KF_ARENA_ARG1`` or ``KF_ARENA_ARG2`` (see section 2.8). > > Emil Tsalapatis suggested in v1 replacing "address_space(1)" with "arena" > throughout the documentation for better readability. This nit was not > addressed in v2. > > The term "address_space(1)" appears in four locations across this commit > (kfuncs.rst, changes.rst, Makefile.btf, and main.c). Would using "arena" > be clearer, especially since the code already defines TYPE_ATTR_ARENA? Nonsense feedback from the bot. Ignoring. > >> + >> 2.7 Specifying no-cast aliases with ___init >> -------------------------------------------- >> >> diff --git a/Documentation/process/changes.rst b/Documentation/process/changes.rst >> index 1ca8c5f73ad00..6d1dbe4abf0f0 100644 >> --- a/Documentation/process/changes.rst >> +++ b/Documentation/process/changes.rst >> @@ -147,10 +147,9 @@ Since Linux 5.2, if CONFIG_DEBUG_INFO_BTF is selected, the build system >> generates BTF (BPF Type Format) from DWARF in vmlinux, a bit later from kernel >> modules as well. This requires pahole v1.22 or later. >> >> -Since Linux 7.0, kfuncs annotated with KF_IMPLICIT_ARGS require pahole v1.26 >> -or later. Without it, such kfuncs will have incorrect BTF prototypes in >> -vmlinux, causing BPF programs to fail to load with a "func_proto incompatible >> -with vmlinux" error. Many sched_ext kfuncs are affected. >> +Kfunc BTF annotations (the bpf_kfunc and bpf_fastcall decl tags and the arena >> +address_space(1) type attribute) are emitted in-tree by resolve_btfids from the >> +BTF_KFUNCS sets, so they no longer depend on a specific pahole version. >> >> It is found in the 'dwarves' or 'pahole' distro packages or from >> https://fedorapeople.org/~acme/dwarves/. >> diff --git a/scripts/Makefile.btf b/scripts/Makefile.btf >> index a1812985a61aa..717e76ce96a71 100644 >> --- a/scripts/Makefile.btf >> +++ b/scripts/Makefile.btf >> @@ -14,6 +14,9 @@ pahole-flags-$(call test-ge, $(pahole-ver), 125) += --skip_encoding_btf_inconsis >> else >> >> # Switch to using --btf_features for v1.26 and later. >> +# >> +# kfunc BTF annotations (bpf_kfunc/bpf_fastcall decl tags and the arena >> +# address_space(1) type attribute) are emitted by resolve_btfids, not pahole. >> pahole-flags-$(call test-ge, $(pahole-ver), 126) = -j$(JOBS) --btf_features=encode_force,var,float,enum64,decl_tag,type_tag,optimized_func,consistent_func >> >> pahole-flags-$(call test-ge, $(pahole-ver), 131) += --btf_features=layout >> diff --git a/tools/bpf/resolve_btfids/main.c b/tools/bpf/resolve_btfids/main.c >> index ea25ca34aa006..66f4014e6aa17 100644 >> --- a/tools/bpf/resolve_btfids/main.c >> +++ b/tools/bpf/resolve_btfids/main.c >> @@ -58,6 +58,17 @@ >> * __BTF_ID__func__vfs_fallocate__5: >> * .zero 4 >> * .word (1 << 3) | (1 << 1) | (1 << 2) >> + * >> + * In addition to resolving BTF IDs, resolve_btfids performs kernel-specific >> + * BTF-to-BTF transformations for kfuncs found in BTF_SET8_KFUNCS sets. For >> + * each such kfunc it: >> + * >> + * - emits a "bpf_kfunc" decl tag, and "bpf_fastcall" when KF_FASTCALL is set; >> + * - wraps the return value and/or arguments flagged KF_ARENA_RET, >> + * KF_ARENA_ARG1 or KF_ARENA_ARG2 with the "address_space(1)" type attribute; >> + * - rewrites the prototype of KF_IMPLICIT_ARGS kfuncs. >> + * >> + * These kfunc annotations were historically produced by pahole. >> */ >> >> #define _GNU_SOURCE > > > --- > AI reviewed your patch. Please fix the bug or email reply why it's not a bug. > See: https://github.com/kernel-patches/vmtest/blob/master/ci/claude/README.md > > CI run summary: https://github.com/kernel-patches/bpf/actions/runs/31056256483