Re: ceph: fix denial of service issue in ceph_update_snap_trace()
Alex Markuze <[email protected]>
| Newsgroups | org.kernel.vger.ceph-devel |
|---|---|
| Message-ID | <[email protected]> |
Hi Slava,
This looks like the right direction to me, but I have a couple of comments.
The Fixes tag seems to point at the later debug-log formatting change. The
WARN/remount path looks like it was introduced by:
a68e564adcaa ("ceph: blocklist the kclient when receiving corrupted snap trace")
so I think that is the better Fixes target.
Also, since `cl` is already in scope here, could you use
`pr_warn_ratelimited_client()` instead of open-coding the `[client.%lld]`
prefix? That keeps the log format consistent with the adjacent
`pr_err_client()` and preserves the fsid in the message.
--
Alex Markuze