Re: fs/ceph/super: document struct ceph_dentry_info and its flags
Alex Markuze <[email protected]>
| Newsgroups | org.kernel.vger.ceph-devel |
|---|---|
| Message-ID | <[email protected]> |
Hi Max,
NACK for now. Thanks for the patch, but I have some concerns
that need a v2:
1. [minor] fs/ceph/super.h:440: CEPH_DENTRY_REFERENCED comment is too narrow
The comment says the bit is set when a dentry on the "shrink list"
is touched again. In practice `__ceph_dentry_dir_lease_touch()`
also sets it when a dentry already on `dentry_dir_leases` is
touched — same second-chance concept, different list. The
dispose-path consumer checks the bit to decide whether to requeue
onto either list.
Suggested fix: Widen to: "set when an already-listed dentry is
touched again, so the walker spares it for another round instead of
disposing of it."
2. [minor] fs/ceph/super.h:422: time field comment says last touched but is insertion/requeue timestamp
3. [nit] fs/ceph/super.h:399: lease_seq comment says REVOKE but client sends REVOKE_ACK
Documentation-only patch with two minor semantic inaccuracies (REFERENCED scope, time semantics) and one naming nit (REVOKE vs REVOKE_ACK); needs a v2.
--
Alex Markuze