Re: [PATCH dt-schema 3/3] schemas: i2c: add generic interrupt name for I2C controllers

Rob Herring <[email protected]>
Newsgroups org.kernel.vger.devicetree-spec,org.kernel.vger.linux-i2c,org.kernel.vger.linux-renesas-soc
Message-ID <CAL_JsqLPGEQ71coq0v2byx5JAGH+FFapv=MCc-AFCwVQ==6M6Q@mail.gmail.com>
On Thu, Aug 15, 2024 at 12:43 PM Wolfram Sang
<[email protected]> wrote:
>
> Hi Rob,
>
> thanks for the super-fast review!
>
> > > "smbus_alert" is a generic interrupt name for controllers, so document
> > > it. Introduce also "irq" for the primary interrupt.
> >
> > I wouldn't add "irq". It's kind of odd in that we have it for I2C
> > devices in the first place and we don't try to do that anywhere else.
>
> Yes, I am actually happy to remove "irq". I only added it for
> consistency.
>
> > > +  interrupt-names:
> > > +    anyOf:
> > > +      - {} # Any name is allowed.
> > > +      - items:
> > > +          enum:
> > > +            - irq
> > > +            - smbus_alert
> >
> > It doesn't really matter with the {}, but the 2nd entry is only true
> > if interrupt-names only contains these 2 names. I'd use 'contains'
> > rather than 'items' here.
>
> So, just replace "items:" with "contains:", right? Should I also change
> this for I2C targets and add this chunk to patch 2?

Oh, I missed that you just copied that, but yes, if you can update
that one too, it would be good.

Rob
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.