Re: reserved-memory: node naming - generic name vs binding recommendation
Rob Herring <[email protected]> Thu, 19 Mar 2026 13:15:49 -0500
| Newsgroups | org.kernel.vger.devicetree-spec |
|---|---|
| Message-ID | <CAL_JsqKRW-=er+DCTob0HmQv9OyVt7yiej-Yht6UR-mcW=LHUg@mail.gmail.com> |
On Thu, Mar 19, 2026 at 10:27=E2=80=AFAM Vitor Soares <[email protected]> wr= ote: > > Hi, > > I have a question about node naming conventions for static reserved-memor= y > allocations. > > The reserved-memory.yaml binding recommends that node names reflect the p= urpose > of the node (e.g. "framebuffer" or "dma-pool"). The base Devicetree > Specification (section 2.2.1) on the other hand recommends using generic = names > from its suggested list, which includes "memory", implying a "memory@<add= r>" > form. > > For nodes with a static allocation, is the binding's guidance to use purp= ose- > reflecting names the recommendation, taking precedence over the base spec= 's > generic "memory@" convention? "memory" is for memory nodes (i.e. ones with 'device_type =3D "memory"'), so not really for reserved-memory nodes. Yes, we would prefer some generic name, but there isn't one defined. Until one is defined, I have little opinion about what name is used (beyond global conventions like don't use '_'). Names reflecting the purpose for /reserved-memory is so widely used already, I don't really think it is something we can go back and fix. Rob