Re: [PATCH v4 1/4] dmaengine: add dma_device_get() helper
Logan Gunthorpe <[email protected]>
| Newsgroups | org.kernel.vger.dmaengine,org.kernel.vger.linux-kernel,org.kernel.vger.stable |
|---|---|
| Message-ID | <[email protected]> |
On 2026-08-17 21:43, Shivank Garg wrote: > Add dma_device_get() helper to match dma_device_put() to make code > symmetric. It wraps open-coded kref_get_unless_zero() and asserts that > dma_list_mutex is held, matching its put counterpart. > > No functional change intended. > > Suggested-by: Frank Li <[email protected]> > Signed-off-by: Shivank Garg <[email protected]> Makes sense to me: Reviewed-by: Logan Gunthorpe <[email protected]>