Re: [PATCH v6 00/15] Create and use APIs to centralise locking for directory ops
Jeff Layton <[email protected]>
| Newsgroups | org.kernel.vger.ecryptfs,dev.linux.lists.netfs,org.kernel.vger.linux-cifs,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-nfs,org.kernel.vger.linux-security-module,org.kernel.vger.linux-unionfs,org.kernel.vger.linux-xfs,org.kernel.vger.selinux |
|---|---|
| Message-ID | <[email protected]> |
On Fri, 2025-11-14 at 13:24 +0100, Christian Brauner wrote: > On Thu, Nov 13, 2025 at 11:18:23AM +1100, NeilBrown wrote: > > Following is a new version of this series: > > - fixed a bug found by syzbot > > - cleanup suggested by Stephen Smalley > > - added patch for missing updates in smb/server - thanks Jeff Layton > > The codeflow right now is very very gnarly in a lot of places which > obviously isn't your fault. But start_creating() and end_creating() > would very naturally lend themselves to be CLASS() guards. > > Unrelated: I'm very inclined to slap a patch on top that renames > start_creating()/end_creating() and start_dirop()/end_dirop() to > vfs_start_creating()/vfs_end_creating() and > vfs_start_dirop()/vfs_end_dirop(). After all they are VFS level > maintained helpers and I try to be consistent with the naming in the > codebase making it very easy to grep. That sounds like a good idea. The current names are a little too generic. -- Jeff Layton <[email protected]>