[PATCH v2 3/5] eta: Use in_ramp_period() instead of opencoding it
Jan Kara <[email protected]> Fri, 19 Dec 2025 14:42:37 +0100
| Newsgroups | org.kernel.vger.fio |
|---|---|
| Message-ID | <[email protected]> |
Reviewed-by: Damien Le Moal <[email protected]> Signed-off-by: Jan Kara <[email protected]> --- eta.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/eta.c b/eta.c index 947752b9dc17..c6e3cffb81d6 100644 --- a/eta.c +++ b/eta.c @@ -274,9 +274,8 @@ static unsigned long thread_eta(struct thread_data *td) uint64_t ramp_time = td->o.ramp_time; t_eta = __timeout + start_delay; - if (!td->ramp_period_over) { + if (in_ramp_period(td)) t_eta += ramp_time; - } t_eta /= 1000000ULL; if ((td->runstate == TD_RAMP) && in_ramp_period(td)) { -- 2.51.0