Re: [PATCH 1/4] common/scsi_debug: don't slow down I/O
Zorro Lang <[email protected]> Sun, 2 Aug 2026 18:35:57 +0800
| Newsgroups | org.kernel.vger.fstests,org.kernel.vger.linux-scsi |
|---|---|
| Message-ID | <am8Yg5NMbLuIOfBd@zlang-mailbox> |
On Thu, Jul 23, 2026 at 04:28:44PM +0200, Christoph Hellwig wrote: > scsi_debug by defaults delays I/O and doesn't support multi-page I/O. > Flipping these defaults speed up each test using scsi_debug by more than > an order of magnitute on my test systems. > > Signed-off-by: Christoph Hellwig <[email protected]> > --- > common/scsi_debug | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > > diff --git a/common/scsi_debug b/common/scsi_debug > index c3fe7be623fa..91665547bc0c 100644 > --- a/common/scsi_debug > +++ b/common/scsi_debug > @@ -59,7 +59,9 @@ _get_scsi_debug_dev() > let physical=physical/2 > let phys_exp=phys_exp+1 > done > - opts="sector_size=$logical physblk_exp=$phys_exp lowest_aligned=$unaligned dev_size_mb=$size $@" > + opts="sector_size=$logical physblk_exp=$phys_exp" > + opts="${opts} lowest_aligned=$unaligned dev_size_mb=$size" > + opts="${opts} delay=0 clustering=1 $@" > echo "scsi_debug options $opts" >> $seqres.full > modprobe scsi_debug $opts While this is syntactically correct, especially when leaving $opts unquoted. But as this patch is trying to to improve code readability, so how about: local opts=( "sector_size=$logical" "physblk_exp=$phys_exp" "lowest_aligned=$unaligned" "dev_size_mb=$size" "delay=0" "clustering=1" ) opts+=("$@") echo "scsi_debug options ${opts[*]}" >> $seqres.full modprobe scsi_debug "${opts[@]}" Thanks, Zorro > [ $? -eq 0 ] || _fail "scsi_debug modprobe failed" > -- > 2.53.0 >