Re: [PATCH 3/4] add: introduce '--resolved' option

Junio C Hamano <[email protected]> Wed, 29 Jul 2026 06:43:37 -0700
Newsgroups org.kernel.vger.git
Message-ID <[email protected]>
Michael Montalbo <[email protected]> writes:

> On Tue, Jul 28, 2026 at 2:58 PM Junio C Hamano <[email protected]> wrote:
>>
>> -       if (addremove && take_worktree_changes)
>> -               die(_("options '%s' and '%s' cannot be used together"), "-A", "-u");
>> +       die_for_incompatible_opt3(take_worktree_changes, "-u/--update",
>> +                                 0 <= addremove_explicit, "-A/--all",
>> +                                 add_resolved, "--resolved");
>>
>
> Should this be "0 < addremove_explicit"?

Thanks for noticing.  '0 <=' is absolutely bogus.

I wonder if we should simply write 'addremove', as this part of the
change is about rewriting the open-coded die_for_incompatible_opt2()
in the original and using die_for_incompatible_opt3() to add a third
option.


>> diff --git a/t/t2207-add-resolved.sh b/t/t2207-add-resolved.sh
>> new file mode 100755
>> index 0000000000..f88e3f413e
>> --- /dev/null
>> +++ b/t/t2207-add-resolved.sh
>
> Does this new test file need a t/meson.build entry?

Yeah, it shows that I rarely exercise meson build.

Thanks.