Re: [PATCH v5 1/2] checkout: improve message for ambiguous remote branch name
Yoichi Nakayama <[email protected]>
| Newsgroups | org.kernel.vger.git |
|---|---|
| Message-ID | <CAF5D8-u+ZxTrmrGDzHvdPS+jDe+bR6ZAYNq5KZ5R-MRpjWedgg@mail.gmail.com> |
On Thu, Aug 20, 2026 at 11:18 AM Junio C Hamano <[email protected]> wrote: > > "D. Ben Knoble" <[email protected]> writes: > > >> +static void be_explicit(const char *branch, > > > > Be explicit about what? Reading below, a better name might be > > "advise_ambiguous_remote_branch_name" or something, idk. > > It stands for "tell the user to be more explicit". I agree with you > that the refactoring should be done as a separate step, on top of > which we should add the new feature, i.e., "give list of possible > candidates", as a separate step. I think it's a good idea to separate the steps, so I'll split the commits. I am considering "advise_disambiguating_remotes" as a better function name. Thanks, -- Yoichi NAKAYAMA