Re: [PATCH 2/3] cld: Add XDR files to gitignore

Jeff Garzik <[email protected]>
Newsgroups org.kernel.vger.hail-devel
Message-ID <[email protected]>
On 02/04/2010 06:30 AM, Colin McCabe wrote:
> Signed-off-by: Colin McCabe<[email protected]>
> ---
>   .gitignore |    4 ++++
>   1 files changed, 4 insertions(+), 0 deletions(-)

While patch #1 seems OK at first glance, patches 2 and 3 definitely 
belong in the big XDR patch, because they refer to things not yet in the 
tree.

Cosmetic patches breaking lines or moving code around are fine, in 
preparation for an upcoming patch.  Those can be thought of as logically 
separate from the big XDR patch, even if they are -preparing- for said 
patch.  For example, I am thinking that the next move might be to move 
existing code into smaller functions as you did -- ie. accept_seqid() -- 
while still keeping the existing, pre-XDR code logic.  That makes the 
diff smaller, easier to read and review, while not specifically doing 
anything XDR related.

	Jeff
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.