Re: [PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
Borislav Petkov <[email protected]> Sat, 13 Sep 2025 07:48:37 +0200
| Newsgroups | org.kernel.vger.initramfs,dev.linux.lists.loongarch,dev.linux.lists.patches,org.infradead.lists.linux-riscv,org.infradead.lists.linux-snps-arc,org.infradead.lists.linux-um,org.kernel.vger.linux-acpi,org.kernel.vger.linux-alpha,org.kernel.vger.linux-api,org.kernel.vger.linux-arch,org.kernel.vger.linux-block,org.kernel.vger.linux-csky,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-doc,org.kernel.vger.linux-efi,org.kernel.vger.linux-ext4,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-hexagon,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k,org.kernel.vger.linux-mips,org.kernel.vger.linux-openrisc,org.kernel.vger.linux-parisc,org.kernel.vger.linux-s390,org.kernel.vger.linux-sh,org.kernel.vger.sparclinux,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <20250913054837.GAaMUFtd4YlaPqL2Ov@fat_crate.local> |
On Sat, Sep 13, 2025 at 12:38:07AM +0000, Askar Safin wrote:
> Rename initrd_start to virt_external_initramfs_start and
> initrd_end to virt_external_initramfs_end.
"virt" as in "virtualization"?
That's not confusing at all... :-\
And "external" means what?
> They refer to initramfs, not to initrd
Why not simply initramfs_{start,end} if they belong to it?
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette