Re: [PATCH RESEND 00/62] initrd: remove classic initrd support
Jessica Clarke <[email protected]> Tue, 16 Sep 2025 18:08:18 +0100
| Newsgroups | org.kernel.vger.initramfs,dev.linux.lists.loongarch,dev.linux.lists.patches,org.infradead.lists.linux-riscv,org.infradead.lists.linux-snps-arc,org.infradead.lists.linux-um,org.kernel.vger.linux-acpi,org.kernel.vger.linux-alpha,org.kernel.vger.linux-api,org.kernel.vger.linux-arch,org.kernel.vger.linux-block,org.kernel.vger.linux-csky,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-doc,org.kernel.vger.linux-efi,org.kernel.vger.linux-ext4,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-hexagon,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k,org.kernel.vger.linux-mips,org.kernel.vger.linux-openrisc,org.kernel.vger.linux-parisc,org.kernel.vger.linux-s390,org.kernel.vger.linux-sh,org.kernel.vger.sparclinux,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <[email protected]> |
On 13 Sep 2025, at 01:37, Askar Safin <[email protected]> wrote: > [...] > For example, I renamed the following global variables: > > __initramfs_start > __initramfs_size > [...] > > to: > > __builtin_initramfs_start > __builtin_initramfs_size I strongly suggest picking different names given __builtin_foo is the naming scheme used for GNU C builtins/intrinsics. I leave you and others to bikeshed that one. Jessica