Re: [PATCH v2 1/2] block: Add bvec_folio()

Hannes Reinecke <[email protected]>
Newsgroups org.kernel.vger.io-uring,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel,org.kvack.linux-mm
Message-ID <[email protected]>
On 5/28/26 19:59, Matthew Wilcox (Oracle) wrote:
> This is a simple helper which replaces page_folio(bvec->bv_page).
> Minor improvement in readability, but the real motivation is to reduce
> the number of references to bvec->bv_page so that it can be changed
> with less work.
> 
> Signed-off-by: Matthew Wilcox (Oracle) <[email protected]>
> Cc: Leon Romanovsky <[email protected]>
> ---
>   block/bio.c          |  6 +++---
>   include/linux/bio.h  |  2 +-
>   include/linux/bvec.h | 15 +++++++++++++++
>   io_uring/rsrc.c      |  2 +-
>   mm/page_io.c         |  4 ++--
>   5 files changed, 22 insertions(+), 7 deletions(-)
> 
Reviewed-by: Hannes Reinecke <[email protected]>

Cheers,

Hannes
-- 
Dr. Hannes Reinecke                  Kernel Storage Architect
[email protected]                                +49 911 74053 688
SUSE Software Solutions GmbH, Frankenstr. 146, 90461 Nürnberg
HRB 36809 (AG Nürnberg), GF: I. Totev, A. McDonald, W. Knoblich
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.