Re: [PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event

Pavel Begunkov <[email protected]> Wed, 22 Jul 2026 21:11:47 +0100
Newsgroups org.kernel.vger.io-uring,org.kernel.vger.netdev
Message-ID <[email protected]>
On 7/22/26 20:37, Mina Almasry wrote:
> On Wed, Jul 22, 2026 at 6:51 AM Pavel Begunkov <[email protected]> wrote:
>>
>> "Notification" is too long and the abbreviated version is used in
>> several places, which is inconsistent and more ambiguous for users.
>> Rename it to event, which is easier to keep consistent. To keep the
>> change small, only change uapi/ + do necessary fix ups, and the rest of
>> internals can be adjusted in the next release.
>>
>> Signed-off-by: Pavel Begunkov <[email protected]>
> 
> Probably a basic question, but isn't the stuff under uapi/ supposed to
> be a stable user api? Why is it not a concern that you're breaking
> current users with this change?

That's so only once it's released. It was done for 7.2, so it's
fine as long as it hits some 7.2-rc*.

-- 
Pavel Begunkov