Re: [PATCH io_uring-7.2 0/3] fix up zcrx "notification" uapi naming
Jens Axboe <[email protected]> Thu, 23 Jul 2026 19:25:17 -0600
| Newsgroups | org.kernel.vger.io-uring,org.kernel.vger.netdev |
|---|---|
| Message-ID | <178485631736.1078734.694232566420857860.b4-ty@b4> |
On Wed, 22 Jul 2026 14:42:14 +0100, Pavel Begunkov wrote:
> There is a degree of inconsistency, nuisance and ambiguity in the naming
> of the zcrx "notification" API. Rename it to "events" and do other small
> adjustments while it's not released yet. The patch set only does
> renaming, there is no functional or ABI changes.
>
> Pavel Begunkov (3):
> io_uring/zcrx: drop "notif" from stats struct names
> io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
> io_uring/zcrx: rename notif to event
>
> [...]
Applied, thanks!
[1/3] io_uring/zcrx: drop "notif" from stats struct names
commit: af78c0020480aba3132fb9fa4db0fd1fb949feaa
[2/3] io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
commit: 201e30810223a40275f17c5e6ee410fa857b6b44
[3/3] io_uring/zcrx: rename notif to event
commit: e366c15e1610ef11d0717ecd875ae63050282676
Best regards,
--
Jens Axboe