[GIT PULL] io_uring fixes for 7.2-rc5
Jens Axboe <[email protected]> Fri, 24 Jul 2026 19:32:39 -0600
| Newsgroups | org.kernel.vger.io-uring |
|---|---|
| Message-ID | <[email protected]> |
Hi Linus,
io_uring fixes for this week:
- Fix a missing ERESTARTSYS conversion in the read paths, which got
messed up back when some code consolidation was done for read
multishot support.
- zcrx UAPI rename, dropping the abbreviated "notif" naming in favor of
"event" for consistency and to be less ambiguous for users. This was
added for 7.2, so let's rename it while we still can. No functional or
code changes, just a strict rename.
Please pull!
The following changes since commit 3afc64c61ce906a04f073ca350b46de10e8302f9:
io_uring/bpf-ops: reject re-registration of an already-bound ops (2026-07-17 11:17:54 -0600)
are available in the Git repository at:
https://git.kernel.org/pub/scm/linux/kernel/git/axboe/linux.git tags/io_uring-7.2-20260724
for you to fetch changes up to e366c15e1610ef11d0717ecd875ae63050282676:
io_uring/zcrx: rename notif to event (2026-07-22 09:48:42 -0600)
----------------------------------------------------------------
Pavel Begunkov (3):
io_uring/zcrx: drop "notif" from stats struct names
io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
io_uring/zcrx: rename notif to event
Yitang Yang (1):
io_uring/rw: fix missing ERESTARTSYS conversion in read paths
include/uapi/linux/io_uring/query.h | 14 ++++++-------
include/uapi/linux/io_uring/zcrx.h | 32 ++++++++++++++--------------
io_uring/query.c | 12 +++++------
io_uring/rw.c | 42 ++++++++++++++++++++++---------------
io_uring/zcrx.c | 34 +++++++++++++++---------------
io_uring/zcrx.h | 7 ++++---
6 files changed, 75 insertions(+), 66 deletions(-)
--
Jens Axboe