Re: [PATCH 1/3] tracing/user_events: Simplify data output in user_seq_show()

Steven Rostedt <[email protected]> Thu, 11 Jun 2026 08:59:49 -0400
Newsgroups org.kernel.vger.kernel-janitors,org.kernel.vger.linux-kernel,org.kernel.vger.linux-trace-kernel
Message-ID <[email protected]>
On Tue, 9 Jun 2026 18:44:04 +0200
Markus Elfring <[email protected]> wrote:

> >> @@ -2800,8 +2800,7 @@ static int user_seq_show(struct seq_file *m, void *p)
> >>  
> >>  	mutex_unlock(&group->reg_mutex);
> >>  
> >> -	seq_puts(m, "\n");
> >> -	seq_printf(m, "Active: %d\n", active);
> >> +	seq_printf(m, "\nActive: %d\n", active);
> >>  	seq_printf(m, "Busy: %d\n", busy);  
> > 
> > This isn't a critical section and I find the original way easier to read.  
> 
> Would you prefer to use a seq_putc() call instead at such a source code place?
> https://elixir.bootlin.com/linux/v7.1-rc7/source/kernel/trace/trace_events_user.c#L2803

Sure, why not.

-- Steve