[Question] list_add() naming: why not list_add_head()?
Ziran Zhang <[email protected]> Fri, 10 Jul 2026 11:19:58 +0800
| Newsgroups | org.kernel.vger.kernel-janitors,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
I noticed list_add() inserts at the head->next, but the name doesn't reflect that. Why wasn't it called list_add_head()? Is there any historical or design reason? Thanks for your time. Regards, Ziran Zhang