Re: [PATCH 0/8] modules: Move 'struct module_signature' to UAPI
Petr Pavlu <[email protected]>
| Newsgroups | org.kernel.vger.keyrings,org.kernel.vger.bpf,org.kernel.vger.linux-integrity,org.kernel.vger.linux-kbuild,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-modules,org.kernel.vger.linux-s390,org.kernel.vger.linux-security-module |
|---|---|
| Message-ID | <[email protected]> |
On 3/2/26 1:42 PM, Thomas Weißschuh wrote: > This structure definition is used outside the kernel proper. > For example in kmod and the kernel build environment. > > To allow reuse, move it to a new UAPI header. > > While it is not a true UAPI, it is a common practice to have > non-UAPI interface definitions in the kernel's UAPI headers. > > This came up as part of my CONFIG_MODULE_HASHES series [0]. > But it is useful on its own and so we get it out of the way. > > [0] https://lore.kernel.org/lkml/aZ3OfJJSJgfOb0rJ@levanger/ > > Signed-off-by: Thomas Weißschuh <[email protected]> This looks reasonable from my side and reduces code duplication. With the removal of MODULE_SIGNATURE_TYPE_MERKLE in patch 6, as reported by the AI, the changes seem ok to me. Feel free to add: Reviewed-by: Petr Pavlu <[email protected]> -- Thanks, Petr