Re: [PATCH RESEND] keys: use kmalloc_flex in user_preparse
Jarkko Sakkinen <[email protected]> Sat, 9 May 2026 18:53:56 +0300
| Newsgroups | org.kernel.vger.keyrings,org.kernel.vger.linux-hardening,org.kernel.vger.linux-kernel,org.kernel.vger.linux-security-module |
|---|---|
| Message-ID | <[email protected]> |
On Mon, May 04, 2026 at 11:31:00AM +0200, Thorsten Blum wrote: > Use kmalloc_flex() when allocating a new struct user_key_payload in > user_preparse() to replace the open-coded size arithmetic and to keep > the size type-safe. > > Signed-off-by: Thorsten Blum <[email protected]> > --- > security/keys/user_defined.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/security/keys/user_defined.c b/security/keys/user_defined.c > index 686d56e4cc85..6f88b507f927 100644 > --- a/security/keys/user_defined.c > +++ b/security/keys/user_defined.c > @@ -64,7 +64,7 @@ int user_preparse(struct key_preparsed_payload *prep) > if (datalen == 0 || datalen > 32767 || !prep->data) > return -EINVAL; > > - upayload = kmalloc(sizeof(*upayload) + datalen, GFP_KERNEL); > + upayload = kmalloc_flex(*upayload, data, datalen); > if (!upayload) > return -ENOMEM; > applied, thanks BR, Jarkko